Why hasn't my Amazon EC2 deployment created a data collector engine?

  • 1 August 2022
  • 1 reply

I've followed the StreamSets documentation to create an AWS Environment and then an Amazon EC2 Deployment, for a single Data Collector engine. I activated the deployment and can view the provisioned EC2 instance within my AWS account. However, in Control Hub, when I navigate to ‘Engines in Deployment’, it has said ‘No Engines Found’, even when the deployment has been active for > 2.5 hrs. I’ve tried restarting the deployment but this didn’t help.

Environment config

AWS region: eu-west-2
Credential Type: Cross-Account Role

Deployment config

Deployment Type: Amazon EC2
Engine for Deployment: Data Collector 5.1.0
Engine Instances: tried 1, then 2
EC2 Instance Type: c4.large

Deployment Event Log
Aug 1, 2022, 2:34:57 PM    INFO        Finished creating stack
Aug 1, 2022, 2:33:25 PM    INFO        Creating stack
Aug 1, 2022, 2:33:24 PM    INFO        Created SSM Parameter Token StreamSets-Deployment-Token-******************************************************************************
Aug 1, 2022, 2:33:24 PM    INFO        Activated deployment token

1 reply

I’ve got it working. I changed to using my AWS account’s default VPC, and then it worked. Previously I was using a new VPC I had created myself (which the StreamSets docs say is recommended, but not required). So it seems I got something wrong when creating my own VPC in AWS, I expect with the security rules.