cdc pipeline shows error .

  • 19 January 2023
  • 1 reply

Userlevel 2

This is my error:QUERY_EXECUTOR_002 - Can't open connection: JDBC_06 - Failed to initialize connection pool: com.zaxxer.hikari.pool.HikariPool$PoolInitializationException: Failed to initialize pool: The TCP/IP connection to the host, port 1433 has failed. Error: "connect timed out. Verify the connection properties. Make sure that an instance of SQL Server is running on the host and accepting TCP/IP connections at the port. Make sure that TCP connections to the port are not blocked by a firewall.".

Actually this pipeline run well on few days ago,now its show error, I THINK  all things are correct  but it shows error 

The same connection string is run on JDBC consumer but when using in Server cdc client its show error. Anyone can fix this and give resolution about the error .








1 reply

Userlevel 2

problem solved As I created a new pipeline the issue solved and don’t know why the issue happens  for previous pipeline.make sure the data length is correct in database this also cause error .