Question

"Disable Read Ahead Stream" config issue

  • 5 January 2023
  • 2 replies
  • 43 views

Hello Team,

We have pipeline where we have ,

SFTP  → S3

It is working only when “Disable Read Ahead Stream”  is enable but it is failing while it is disabled.

I am facing below error,

Unable to write object to Amazon S3, reason : com.amazonaws.SdkClientException: Unable to execute HTTP request: No such file

 

Could you please assist with this error ?

 


2 replies

Userlevel 3
Badge +1

@yogesh0590 

May i know the data format in sftp which is causing problem in sending data to S3 bucket.

Please provide me the sftp configuration details , i will try to reproduce the issue and will try to provide the resolution.

Attached the screenshot for which case the “Disable Read Ahead Stream” is helpful.

 

Thanks & Regards

Bikram_

Userlevel 3
Badge +1

@yogesh0590 

I have the below configurations in sftp origin and i could manage to send files to s3 with no issues. 

 

Reply