preview doesn't show the records data.

  • 2 August 2022
  • 5 replies

Hello , i created a pipeline and it runs without errors , the output is as expected which is 2777 records however when i run preview it shows no data records except for the one in the screenshot below .
and i couldn’t know why this happens .



Best answer by N_ali 22 August 2022, 23:38

View original

5 replies

Userlevel 3

Data Collector keeps track of an offset at the origin which is intended to avoid duplicating data if you run the pipeline again. I think that same offset management is what's preventing data from showing up in the preview. 

if you do choose to reset the origin offset, it should start showing up. 

i reset the origin and ran the pipeline again but it displayed the same thing above.

i tried new files for ftp to process it but the same thing happens it displays the count but i can’t preview the data 

i did the reset from here.

Userlevel 5
Badge +1


i can see the sftp origin is showing ‘0’ records , can you please check if you have the file exists in it which one you are trying to retrieve and also check the file format as well .

Try to run the pipeline and also check if you manage to read data from the file itself or not.

i figured out the problem , 
it turns out that when i enable on archive in SFTP/FTPS client , the result data won’t show in the preview.
i disabled the on archive and it is now shown again.