While establishing JDBC connection.

I am getting this type of error JDBC_00 - Cannot connect to specified database: com.mysql.cj.jdbc.exceptions.CommunicationsException. Can anybody help me in this.


12 replies

Userlevel 2

Hi @Akanksha,

This is an exception coming from MySQL driver, basically we are not able to establish the connection.

Quickly googling it, I’ve found this that might help you troubleshoot

Actually, I tried everything but than also not able to establish connection. So could you please tell me, is there any other way to establish a JDBC connection.

Userlevel 2

Have you tried doing a ping to the machine where the MySQL is located? Are we sure it is reachable? (Not blocked by a firewall or things like that)

Its Resolved automatically. Thanks for helping @alex.sanchez .

Hello @alex.sanchez ,

I am actually experiencing the same issue. I was wondering if @Akanksha had shared what solved this issue? I have a server set up locally that I need to connect to yet I am receiving this error. I’m working off a Mac. I’ve also downloaded the MySQL driver and have added it as a external resource but I’m still until able to connect. I’ve also checked that my firewall is open. Any other suggestions to resolve this?? 

Thanks in advance!

Userlevel 4


Make sure your data collector has access to the database.

Hi @saleempothiwala ,

Is there a specific place I should be checking to make sure of that? 

Thank you! 

Userlevel 4

@JoeMeszaros are you using docker for SDC?

If yes, then make sure your sdc docker is in the same docker network as your database.
you can validate it by docker exec into your instance and do a ping to the database.

@saleempothiwala got it! Let me give that a try. 

Userlevel 4

cool. Let me know how it goes :-)

Hi @saleempothiwala 

It seems as though both the SDC and mysqldb are on the same network but I’m still getting the same error.


Userlevel 5
Badge +1


can you please give a try with below jdbc connection string.